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Using Personalizations and Other Techniques to Give Your Self-Service 
Applications a Custom Look and Feel 

 
By Don Driggs, Solution Beacon LLC 
 
Paper Abstract 
Release 11.5.10 provides a new, fantastic tool for the self-service applications to give them a custom look 
and feel.  You can use this tool, personalizations, to change headings, hide fields, move them around, and 
more.  And the best part of all this is you don’t need to be a techie to use it. 
 
Executive Summary 
Carnegie Mellon University recently upgraded their applications from 11.0.3 to 11.5.10 CU2.  One of the 
significant customizations they were using and didn’t want to carry forward was their integration of the 
procurement card to Oracle Grants Accounting.  While the procurement card transaction process is not 
integrated with Grants in 11.5.10, internet expenses is so they converted all their procurement cards to 
travel cards and used iExpenses to process their procurement card transactions.   
 
CMU was already using Internet Expenses or Expense Reporting as it was known in 11.0.3 to handle their 
travel-related expense reporting so they made a few adaptations to give iExpenses a look and feel that 
would make their Procurement Card users feel at home.  They changed the names of page headings, 
column headings, removed unwanted web links, hid some columns and moved some others around.  They 
defaulted in some information to some fields, changed button names, and hid other buttons. 
 
All of this was done using personalizations by a functional user and no technical expertise was necessary. 
 
 
Paper and Presentation Notes 
This training session will demonstrate how you can change the look and feel of your self-service 
applications.  We will show how you can use personalizations and messages to give your self-service 
applications a custom look and feel. 
 
To do this, we will demonstrate some of the things we did at Carnegie Mellon University to use the Internet 
Expenses application to process our Procurement Card transactions.  CMU developed a stand-alone module 
to handle procurement card transactions when they implemented 11.0.3.  They needed something that 
integrated with Oracle Grants and in 1999 that process wasn’t part of the Oracle applications.  During the 
upgrade to 11.5.10, CMU re-evaluated this customization.   
 
Let me emphasize that this paper is not about how CMU adapted internet expenses so they could process 
procurement card transactions.  It is about how CMU used personalizations to help them use internet 
expenses to process their procurement card transactions. 
 
The standard Oracle procurement card process in 11.5.10 isn’t integrated with Grants but Internet Expenses 
is.  So the question was asked, could iExpenses handle procurement card transactions?   
 
There are similarities between the two processes.  Both processes download credit card transactions, the 
user reviews and verifies the accounts and amounts and submits them for approval.  In addition, they found 
the benefits of using iExpenses for both sets of transactions were that: 

• The users would have the same tool to handle their credit card and travel transactions. 
• There would be efficiencies in training and supporting the users. 
• The procedures and guidelines for approving travel and procurement card expenses would become 

more consistent. 
• Policy decisions could be enforced uniformly. 

 
There are differences in the processes too.  Procurement card transactions are company paid, there are no 
cash or out of pocket transactions.  The Expense Report Templates are unique and need to be segregated.  
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Procurement polices are different than travel policies and there are differences in terminology.  For 
example, no travel-related costs are allowed on the procurement card – they are for the procurement of 
goods and services.  The cards are restricted for travel-related suppliers such as airlines, car rental agencies, 
and hotels.  There is a monthly limit on the amount that can be charged to a procurement card.  No out-of-
pocket charges can be included in the validation of procurement card transactions.  
 
These distinctions required CMU to create a custom look and feel to Internet Expenses for procurement 
cards without impacting the travel expense reporting process.  Personalizations was the perfect answer to 
resolve many of these requirements. 
 
Using personalizations, CMU was able to use the same application for both process but still maintain 
separate policies and control.  This session will demonstrate on a limited basis how CMU used 
personalizations to segregate the two processes.  In doing so, it will demonstrate various ways that 
personalizations can touch the look and feel of your self-service applications.  Even though we are using 
Internet Expenses to demonstrate personalizations, they apply to all self-service applications. 
 
Even though we are discussing internet expenses, this demonstration of personalizations applies to any self-
service Oracle application. 
 
What Are Personalizations? 
Personalizations refer to the ability to tailor the self-service applications, specifically the look and feel, the 
layout and the visibility of the content.   
 
Oracle refers to this technology as the Oracle Applications Framework Personalization.  The OA 
Framework Release 5.7 is available if you are at 11.5.9 and have applied rollup patch 3323690.  It is a 
standard feature on 11.5.10. 
 
You can tell that these features are available if in the upper right-hand corner of the home page of the 
Oracle E-business suite, you have a Personalize Page link. 
 

 
 
 
There is a profile options that can hide this link.  It is called Personalize Self-Service Defn so if you don’t 
see the link, you might check the profile option.  The value should be set to Yes to see the links.  That is the 
default value.  
 
Don’t confuse these OAF personalizations with the core application form personalizations.  To personalize 
a core application form requires the database password and skills typically found in an application 
developer.  The OAF personalizations allow a somewhat skilled functional user to change screens (or 
pages) in the self-service application without impacting the core application forms. 
 
 
How do I use Personalizations? 
 
EXPENSES HOME PAGE 

1.  Remove buttons  

Change Link Path Level Personalize 

Remove the Import 
Spreadsheet button 

Personalize 
Page 

Page Layout: Expenses Home > 
Page Button Bar: > Button: Import 
Spreadsheet 

Responsibility Rendered = False 

Remove the Export 
Spreadsheet button 

 Page Button Bar: > Button: Export  
Spreadsheet 

Responsibility Rendered = False 
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Personalizations allow you to make changes at various levels of activity with the lowest level of activity 
taking precedence over a higher level of activity.  The levels of applying personalizations are: 
 
Function:  Admin can define functions and can define granular level personalization based upon these 
functions. For example, two functions can be created for same form based upon the functionality of Update 
only and one for creating records. And then personalization can be defined for each function. 
Site:  Personalizations that affect all users with access to the given application component. 
Operating Unit:  Personalizations that affect all users with access to the given operating unit. 
Responsibility:  Personalizations that affect all users with access to the given responsibility. 
 
The default values for every personalization are defined in the first column and inherited at every 
descending level of activity.  If the value is changed at any level, then all lower levels inherit the changed 
valued.  The term inherit is used frequently and means that the level inherits the definition from the level 
immediately above it.  Using the above example, a value of false at the site level means that the value will 
be false for all operating units and for all responsibilities that access that page.  However, I can override 
that by setting one value at a high level and a different value at a lower level.  If I entered False for 
Rendered at the Operating Unit level and True at the Responsibility level, then that responsibility would see 
the buttons but no one else in that operating unit would. 
 
This feature of applying personalizations at various levels enabled us to differentiate our travel expense 
reporting from our procurement card reporting because we created a unique responsibility for both. 
 

2. Change the button name 

Change Link Path Level Personalize 

Change button name:  From 
Create Expense Report to 
Create  Credit Card 
Verification Report. 

Personalize 
Page 

Page Layout: Expenses Home > 
Page Button Bar: >  
Button: Create Expense Report 

Responsibility 
– 
Procurement 
Card 

Prompt = Create 
Verification Report 

 
3. Change the Header 

Change Link Path Level Personalize 

Change Header “Track 
Submitted Expense Reports” 
to “Track Submitted Credit 
Card Verification Reports” 

Personalize 
"OIE Home 
Page 
Container" 

Default Single Column > Header: 
Track Submitted Expense Reports 

Responsibility 
– 
Procurement 
Card 

Text = Track 
Submitted Credit 
Card Verification 
Reports 

Change Header “Update 
Expense Reports” to “Update 
Credit Card Verification 
Reports” 

 Default Single Column > Header: 
Update Expense Reports 

Responsibility 
– 
Procurement 
Card 

Text = Update 
Credit Card 
Verification Reports 

 
4. Hide the Duplicate Column 

Change Link Path Level Personalize 

Remove Duplicate Option 
from the Track Submitted 
PCard Verification Report 
table 

Personalize 
Page 

Page Layout: Procurement Card 
Home->Header: Track Submitted 
PCard Verification Reports-
>Switcher: Duplicate 

Responsibility 
– 
Procurement 
Card 

Rendered=False 

 
 
GENERAL INFORMATION PAGE 

5. Change a Field Name 

Change Link Path Level Personalize 

Change Expense Cost Center 
to Default Organization 
Number 

Personalize 
Page 

Page Layout > Page Button Bar: > 
Page Button Bar: Actions Region > 
Message Text Input: Expense Cost 
Center 

Site Prompt = Default 
Organization 
Number 
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6. Set the Initial Value 

Change Link Path Level Personalize 

Default the Purpose to PCard 
Verification 

Personalize 
Page 

Page Layout > Page Button Bar: > 
Page Button Bar: Actions Region >  
Message Text Input: Purpose 

Responsibility 
–  
Procurement 
Card 

Initial Value = 
PCard Verification 

And make the purpose read 
only 

   Rendered = True 

 
 
7. Hide one of the Train Links 

Change Link Path Level Personalize 

Remove the Cash and Other 
Expenses from the Navigation 
Train 

Personalize 
Page 

Page Layout > location > Train: 
OIE Train > Link: Cash and Other 
Expenses 

Responsibility 
–  
Procurement 
Card 

Rendered = False 

 
 
CREDIT CARD EXPENSES 

8. Change date to be non-updatable 

Change Link Path Level Personalize 

Change the Date to be Non-
Updatable 

Personalize 
Page 

Page Layout > Flow Layout: Credit 
Card Expenses > Header: Business 
Expenses > Table > Switcher Error 
> Message Text Input: Date 

Site Read Only = True 

 
 
Demonstrate the use of  
Focus:  Displays only those items in that grouping,  
Expand All:  Display items at all levels,  
Collapse All: Hide items at all levels,  
Simple View:  Display the focused items 
Complete View:  Display all components 
Find (Ctrl F):  Browser tool to find key words 

 
 
9. Change Column Heading 

Change Link Path Level Personalize 

Change the Heading Itemize 
to Split 

Personalize 
Page 

Page Layout > Header: Business 
Expenses > Table > Switcher Error 
> Image: Itemize 

Site Prompt = Split 

 
 
 
10. Reorder the Columns 

Change Link Path Level Reorder 

Reorder the display of the 
columns in the Site  
 

Personalize 
Page 

Page Layout > Header: Business 
Expenses > Table  

Site  

Click on the Personalize box 
in the Site section 

    

Use the arrows to reorder the 
columns 
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11. Create an Item – Add Employee Name to Cash and Other Expenses 

Change Link Path Level Reorder 

Add a field call Employee 
Name to the Cash and Other 
Expenses page 
 

Personalize 
“Receipt-
Based 
Expenses” 

Default Single Column: Receipt-
Based Expenses 

  

Enter the following:  *ID:  EmloyeeName 
CSS Class:  OraDataText 
Prompt:  Employee Name 
View Attribute:  FullName 
View Instance:  PersonsVO 

  

Reorder  Move Employee Name above Split 
and Receipt Based Expenses 
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12. Create an Item – Add a Tip for Cash and Other Expenses 

Change Link Path Level Reorder 

Add a message using the 
Application Developer 

    

Add that message as a tip to 
the Cash and Other Expenses 
page 

    

 
 

 
 
 
 
Questions: 
Are personalizations upgradeable?  Yes 
 
Can they be migrated to other instances?  Yes 
 
How do you manage personalizations? 
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Managing Personalizations 
Functional Administrator responsibility 

Personalizations Tab 
 

Enter the Document name in the Document Path 
Hint:  Before switching to the Functional Administrator responsibility, go to the page that’s been 
personalized and swipe the Document Name and copy it.  Then using the Functional 
Administrator responsibility, navigate to the Personalizations tab and paste it into the Document 
Path and click Go. 
 

 
 
 

 Click the Manage Personalizations icon 

 
Here, you can Deactivate, Activate, or Delete personalizations. 
 
Use the Extract and Upload buttons to migrate personalizations to other instances.  Preliminary steps are 
required before doing such as defining the common server location where all the personalizations will be 
put into and read from.  This will take technical expertise beyond the scope of this paper. 
 
About this Page 
Find this link in the lower left-hand corner of every self-service page.  Click on this link to see 
Personalizations, Patches, and lots of useful (depending on who you talk to) stuff.   
 
Items listed in the Manage Personalizations page identify the pages that have been personalized and even 
the level to which they were applied but they don’t identify specifically what was personalized.  You can 
find that information by navigating to that page and clicking on the About this Page link. 
 
Personalizations are cool, easy to use, easy to manage, and upgradeable. 
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